MyPost Business Payment incident.

Resolved

This incident has been resolved.
Posted May 27, 2026 - 14:16 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 27, 2026 - 09:37 AEST

Investigating

We’re currently experiencing an issue that affects payments for MyPost Business services. We’re working to resolve this issue as a priority.
Posted May 27, 2026 - 09:27 AEST
This incident affected: Mypost Business (Payment).