Credit Card Payment Not Available

Resolved

This incident has been resolved.
Posted 1 month ago. Apr 14, 2025 - 11:39 AEST

Investigating

We are experiencing an issue with MyPost Business credit card payments from 10:30 AM Monday, April 14. PayPal payments are not impacted. Our team is actively investigating the issue. We apologize for any inconvenience and appreciate your patience.
Posted 1 month ago. Apr 14, 2025 - 11:17 AEST
This incident affected: Mypost Business (Payment).