Parcel Send outage - 28th July, 2021
Resolved
This incident has been resolved.
Posted Jul 28, 2021 - 12:43 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2021 - 12:30 AEST
Investigating
We are currently experiencing technical issues that is impacting the ability of some users to log into Parcel Send. Our teams are working hard to resolve this issue as quickly as possible. We sincerely apologise for any inconvenience caused.
Posted Jul 28, 2021 - 12:15 AEST
This incident affected: Parcel Send.